aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyperf_2.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-22 13:35:39 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-26 08:55:41 -0700
commit122f33d974e8a24c487454288d73d249a1dc7326 (patch)
tree9550deb04d7c1fd7accf858b7ecb540191002917 /meta-python/recipes-devtools/python/python3-pyperf_2.0.0.bb
parentd4e1bfe5472eb03a9f51db6d1b576a598b0e15cd (diff)
downloadmeta-openembedded-contrib-122f33d974e8a24c487454288d73d249a1dc7326.tar.gz
python3-pyperf: Upgrade 1.7.1 -> 2.0.0
Upgrade to release 2.0.0: - Drop Python 2 support - Fix test_runner on PyPy3 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyperf_2.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperf_2.0.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyperf_2.0.0.bb b/meta-python/recipes-devtools/python/python3-pyperf_2.0.0.bb
new file mode 100644
index 0000000000..7ced7d0174
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperf_2.0.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "A toolkit to write, run and analyze benchmarks"
+DESCRIPTION = " \
+The Python pyperf module is a toolkit to write, run and analyze benchmarks. \
+Features: \
+ * Simple API to run reliable benchmarks \
+ * Automatically calibrate a benchmark for a time budget. \
+ * Spawn multiple worker processes. \
+ * Compute the mean and standard deviation. \
+ * Detect if a benchmark result seems unstable. \
+ * JSON format to store benchmark results. \
+ * Support multiple units: seconds, bytes and integer. \
+"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=78bc2e6e87c8c61272937b879e6dc2f8"
+
+SRC_URI[md5sum] = "7f62d3f6fc5475138791d3d883fdf4cd"
+SRC_URI[sha256sum] = "2189fbc4af08d519f85468e70e32c902eab0f1341b2c41028b94b2832d3169a7"
+
+DEPENDS += "${PYTHON_PN}-six-native"
+
+PYPI_PACKAGE = "pyperf"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-misc"