aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-01 17:22:42 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:19:38 -0700
commitc05c460510a587a7489a11eeddd789223b5dba93 (patch)
tree327adc1853d477d8bfc0e11bd12b2e2ecb55efca /meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
parent2249f81f8c5cda614532f43e255f697fe3fdfb3f (diff)
downloadmeta-openembedded-contrib-c05c460510a587a7489a11eeddd789223b5dba93.tar.gz
python3-pyperclip: Upgrade 1.7.0 -> 1.8.0
Upgrade to release 1.8.0: - Correcting a URL - Updating code and docs with waitForPaste() and waitForNewPaste() functions. Use the exact line with license information from PKG-INFO. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb b/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
new file mode 100644
index 0000000000..8f331529a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyperclip_1.8.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A cross-platform clipboard module for Python. (only handles plain text for now)"
+HOMEPAGE = "https://github.com/asweigart/pyperclip"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=d7dd4b0d1f7153322a546e89b5a0a632"
+
+SRC_URI[md5sum] = "c2564a74b909b6fc32401afd619de83d"
+SRC_URI[sha256sum] = "b75b975160428d84608c26edba2dec146e7799566aea42c1fe1b32e72b6028f2"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+"
+
+BBCLASSEXTEND = "native nativesdk"