aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyopenssl_20.0.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-13 16:26:20 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-14 11:58:30 -0800
commit43c16133c45455dab9cd215ab5e521cd32213166 (patch)
tree6020e1ef9e1e734560f1965218970dfd39f2c1d5 /meta-python/recipes-devtools/python/python3-pyopenssl_20.0.1.bb
parent48aa4712e53f91cfc3816bd693966bbe411754c1 (diff)
downloadmeta-openembedded-contrib-43c16133c45455dab9cd215ab5e521cd32213166.tar.gz
python3-pyopenssl: Upgrade 19.1.0 -> 20.0.1
Upgrade to release 20.0.1: - Fixed compatibility with OpenSSL 1.1.0 - Added a new optional chain parameter to OpenSSL.crypto.X509StoreContext() where additional untrusted certificates can be specified to help chain building. - Added OpenSSL.crypto.X509Store.load_locations to set trusted certificate file bundles and/or directories for verification. - Added Context.set_keylog_callback to log key material. - Added OpenSSL.SSL.Connection.get_verified_chain to retrieve the verified certificate chain of the peer. - Make verification callback optional in Context.set_verify. If omitted, OpenSSL’s default verification is used. - Fixed a bug that could truncate or cause a zero-length key error due to a null byte in private key passphrase in OpenSSL.crypto.load_privatekey and OpenSSL.crypto.dump_privatekey. - Deprecated OpenSSL.crypto.loads_pkcs7 and OpenSSL.crypto.loads_pkcs12. - The minimum cryptography version is now 3.2. - Remove deprecated OpenSSL.tsafe module. - Removed deprecated OpenSSL.SSL.Context.set_npn_advertise_callback, OpenSSL.SSL.Context.set_npn_select_callback, and OpenSSL.SSL.Connection.get_next_proto_negotiated. - Drop support for Python 3.4 - Drop support for OpenSSL 1.0.1 and 1.0.2 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyopenssl_20.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyopenssl_20.0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyopenssl_20.0.1.bb b/meta-python/recipes-devtools/python/python3-pyopenssl_20.0.1.bb
new file mode 100644
index 0000000000..e121ef8444
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyopenssl_20.0.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Simple Python wrapper around the OpenSSL library"
+HOMEPAGE = "https://pyopenssl.org/"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS += "openssl ${PYTHON_PN}-cryptography"
+
+SRC_URI[sha256sum] = "4c231c759543ba02560fcd2480c48dcec4dae34c9da7d3747c508227e0624b51"
+
+PYPI_PACKAGE = "pyOpenSSL"
+inherit pypi setuptools3
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
+
+RDEPENDS_${PN}_class-target = " \
+ ${PYTHON_PN}-cryptography \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-threading \
+"
+RDEPENDS_${PN}-tests = "${PN}"
+
+BBCLASSEXTEND = "native nativesdk"