aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-01 17:22:43 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:19:43 -0700
commit21dc01b54f33c3c65aa4e6ea4920026e3a539310 (patch)
treed5af9a892dcc05d39a7a2af8f24f4cfecd43b762 /meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.2.bb
parentc05c460510a587a7489a11eeddd789223b5dba93 (diff)
downloadmeta-openembedded-contrib-21dc01b54f33c3c65aa4e6ea4920026e3a539310.tar.gz
python3-pyhamcrest: Upgrade 1.9.0 -> 2.0.2
Upgrade to release 2.0.2: - Various type hint bug fixes. - Make hamcrest package PEP 561 compatible, i.e. supply type hints for external use. - Drop formal support for 2.x - Drop formal support for 3.x < 3.5 - Fix raises() grows support for additional matchers on exception object. - Made has_properties() report all mismatches, not just the first. - Silence warnings. - Type fixes. - Remove obsolete dependencies. The year in LICENSE.txt has been updated and the LIC_FILES_CHKSUM changed. The license remains the same. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.2.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.2.bb b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.2.bb
new file mode 100644
index 0000000000..59d9b5e8b3
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyhamcrest_2.0.2.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Hamcrest framework for matcher objects"
+HOMEPAGE = "https://github.com/hamcrest/PyHamcrest"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=79391bf1501c898472d043f36e960612"
+
+PYPI_PACKAGE = "PyHamcrest"
+
+SRC_URI[md5sum] = "7a086f0b067f8d38958ec32f054559b4"
+SRC_URI[sha256sum] = "412e00137858f04bde0729913874a48485665f2d36fe9ee449f26be864af9316"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-six"