aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyflakes_2.3.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-25 15:34:32 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-26 10:32:33 -0700
commita028581d60352cb47057c9a1ae5971c90fe404a5 (patch)
tree11644095c43fa9263c9b3fe2c5b58e7ee26fec53 /meta-python/recipes-devtools/python/python3-pyflakes_2.3.1.bb
parent9c3e50528dd501c807059f347330c2c7dcca6282 (diff)
downloadmeta-openembedded-contrib-a028581d60352cb47057c9a1ae5971c90fe404a5.tar.gz
python3-pyflakes: Upgrade 2.3.0 -> 2.3.1
Upgrade to release 2.3.1: - Allow passing tox positional arguments to unittest - Annotations no longer redefine names Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyflakes_2.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyflakes_2.3.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyflakes_2.3.1.bb b/meta-python/recipes-devtools/python/python3-pyflakes_2.3.1.bb
new file mode 100644
index 0000000000..69680ddcba
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyflakes_2.3.1.bb
@@ -0,0 +1,15 @@
+SUMMARY = "passive checker of Python programs"
+HOMEPAGE = "https://github.com/dreamhost/cliff"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=690c2d09203dc9e07c4083fc45ea981f"
+
+SRC_URI[sha256sum] = "f5bc8ecabc05bb9d291eb5203d6810b49040f6ff446a756326104746cc00c1db"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-prettytable \
+ ${PYTHON_PN}-cmd2 \
+ ${PYTHON_PN}-pyparsing"
+
+BBCLASSEXTEND = "native nativesdk"