aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-17 18:46:50 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-17 22:27:14 -0800
commitdec5ceaacbfc9b56dcf6e8e31d06a390a1185f5f (patch)
treeafe5a4617bae8c8d8902faa34c299da36d7f4135 /meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb
parent7002e7dd3767755c2b6ea7ccbecf6f78822e8eb0 (diff)
downloadmeta-openembedded-contrib-dec5ceaacbfc9b56dcf6e8e31d06a390a1185f5f.tar.gz
python3-pyflakes: Add python3 version
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb b/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb
new file mode 100644
index 0000000000..c138822400
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyflakes_2.1.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "passive checker of Python programs"
+HOMEPAGE = "https://github.com/dreamhost/cliff"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://README.rst;md5=5127315117a8561a1504343d59620647"
+
+SRC_URI[md5sum] = "a0f71a15724e553c46e03ba5ed56703c"
+SRC_URI[sha256sum] = "d976835886f8c5b31d47970ed689944a0262b5f3afa00a5a7b4dc81e5449f8a2"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-prettytable \
+ ${PYTHON_PN}-cmd2 \
+ ${PYTHON_PN}-pyparsing"
+
+BBCLASSEXTEND = "native nativesdk"