aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-05 14:39:29 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 14:27:45 -0700
commitc4d22546edf72d21a11d59dc4b23b4bf6fdd8a72 (patch)
tree775f9d97f3c842b1accc04705690e779dfd21659 /meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
parent72eaf6a0ea7a85749d90f0f051354ebe8574de42 (diff)
downloadmeta-openembedded-contrib-c4d22546edf72d21a11d59dc4b23b4bf6fdd8a72.tar.gz
python-pydbus: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
index adaa86d5a2..931bc6f7cb 100644
--- a/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pydbus_0.6.0.bb
@@ -1,6 +1,17 @@
-require python-pydbus.inc
-inherit pypi setuptools3
+DESCRIPTION = "Pythonic DBus library"
+HOMEPAGE = "https://pypi.python.org/pypi/pydbus/"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a916467b91076e631dd8edb7424769c7"
SRC_URI += "file://0001-Support-asynchronous-calls-58.patch \
file://0002-Support-transformation-between-D-Bus-errors-and-exce.patch \
"
+
+SRC_URI[md5sum] = "c6abd44862322679bd4e907bebc3e0d0"
+SRC_URI[sha256sum] = "4207162eff54223822c185da06c1ba8a34137a9602f3da5a528eedf3f78d0f2c"
+
+inherit pypi setuptools3
+
+S = "${WORKDIR}/pydbus-${PV}"
+
+RDEPENDS_${PN} = "${PYTHON_PN}-pygobject"