aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pycurl_7.44.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-16 17:12:31 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-17 08:11:16 -0700
commitaa2201d98909c55c3075634ac79b729d6f83bf66 (patch)
treeceedf347889033ead40f1b0584d7d7849ca21e5c /meta-python/recipes-devtools/python/python3-pycurl_7.44.1.bb
parent26a6ddc70b12e90b9791dddf57225a5b7d99ccb7 (diff)
downloadmeta-openembedded-contrib-aa2201d98909c55c3075634ac79b729d6f83bf66.tar.gz
python3-pycurl: Upgrade 7.44.0 -> 7.44.1
Upgrade to release 7.44.1: - Repair incorrect Python thread initialization logic which caused operations to hang Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pycurl_7.44.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pycurl_7.44.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pycurl_7.44.1.bb b/meta-python/recipes-devtools/python/python3-pycurl_7.44.1.bb
new file mode 100644
index 0000000000..a80fed62de
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycurl_7.44.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "A Python Interface To The cURL library"
+DESCRIPTION = "\
+PycURL is a Python interface to libcurl, the multiprotocol file \
+transfer library. Similarly to the urllib Python module, PycURL can \
+be used to fetch objects identified by a URL from a Python program \
+"
+SECTION = "devel/python"
+HOMEPAGE = "http://pycurl.io/"
+
+LICENSE = "LGPLv2 | MIT"
+LIC_FILES_CHKSUM = "file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING-MIT;md5=75f131c591546fd1277ca49c9a81ab1b \
+ "
+
+SRC_URI[sha256sum] = "5bcef4d988b74b99653602101e17d8401338d596b9234d263c728a0c3df003e8"
+
+inherit pypi setuptools3
+
+DEPENDS = "\
+ curl \
+ ${PYTHON_PN}\
+"