aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.6.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-02 11:33:42 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-05 13:04:00 -0700
commit04470663c4a5769e5fda70a21688cd6b108a578c (patch)
tree18534deb63131c0b3950079740ff86b83fd41522 /meta-python/recipes-devtools/python/python3-pycurl_7.43.0.6.bb
parent5777d30ef39044041a33013294780e6b8e560727 (diff)
downloadmeta-openembedded-contrib-04470663c4a5769e5fda70a21688cd6b108a578c.tar.gz
python3-pycurl: Upgrade 7.43.0.5 -> 7.43.0.6
Upgrade to release 7.43.0.6: - Improve SSL backend detection on various systems - Add support for libcurl's multiple SSL backend functionality - Add support for several libcurl options Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pycurl_7.43.0.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pycurl_7.43.0.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.6.bb b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.6.bb
new file mode 100644
index 0000000000..0437a6cc93
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycurl_7.43.0.6.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A Python Interface To The cURL library"
+DESCRIPTION = "\
+PycURL is a Python interface to libcurl, the multiprotocol file \
+transfer library. Similarly to the urllib Python module, PycURL can \
+be used to fetch objects identified by a URL from a Python program \
+"
+SECTION = "devel/python"
+HOMEPAGE = "http://pycurl.io/"
+
+LICENSE = "LGPLv2 | MIT"
+LIC_FILES_CHKSUM = "file://COPYING-LGPL;md5=4fbd65380cdd255951079008b364516c \
+ file://COPYING-MIT;md5=60872a112595004233b769b6cbfd65b6 \
+ "
+
+SRC_URI[md5sum] = "3e121d895101022c30619e1bbf97eb97"
+SRC_URI[sha256sum] = "8301518689daefa53726b59ded6b48f33751c383cf987b0ccfbbc4ed40281325"
+
+inherit pypi setuptools3
+
+DEPENDS = "\
+ curl \
+ ${PYTHON_PN}\
+"