aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
diff options
context:
space:
mode:
authorMing Liu <liu.ming50@gmail.com>2020-01-25 15:19:53 +0100
committerKhem Raj <raj.khem@gmail.com>2020-01-25 12:44:25 -0800
commitbd85cf0642b9e5467da0ba91a3308d53410e7ece (patch)
tree67b612381535bb4fa8d9efb5120a5a5861fff8a9 /meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
parent680aadb4bfd993a00bc75e02a9dfa4a580cdb86b (diff)
downloadmeta-openembedded-contrib-bd85cf0642b9e5467da0ba91a3308d53410e7ece.tar.gz
python3-pycrypto: drop time.clock
The use of time.clock() is deprecated in python 3.8, change to use time.process_time(). Reference: https://docs.python.org/3.3/library/time.html#time.clock Signed-off-by: Ming Liu <liu.ming50@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
index 02d634cb00..a20eafec43 100644
--- a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
+++ b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
@@ -1,6 +1,8 @@
inherit distutils3
require python-pycrypto.inc
+SRC_URI += "file://0001-Replace-time.clock-with-time.process_time.patch"
+
# We explicitly call distutils_do_install, since we want it to run, but
# *don't* want the autotools install to run, since this package doesn't
# provide a "make install" target.