aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
diff options
context:
space:
mode:
authorRicardo Silva <rjpdasilva@gmail.com>2018-01-04 18:13:46 +0000
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:38:09 -0800
commitc06be20b249d023849726ee752b76816ccf2e9f4 (patch)
tree036fb3745034c846c6f5f026bd59d104eefeb7c7 /meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
parent582b5aae6f4d69a763c4c17014e07f1af8df5eea (diff)
downloadmeta-openembedded-contrib-c06be20b249d023849726ee752b76816ccf2e9f4.tar.gz
pycrypto: Add recipe to have support on python3
The pycrypto module sources can be used for both python2 and python3, but a recipe for python3 was missing, so add it. Additionally, since the sources (and thus the patches) are shared between both versions, move the SRC_URI (same on both recipes) to the common 'python-pycrypto.inc' file, to avoid duplication. Also, to use the same patch files for both python2 and python3 without having to duplicate them over 2 folders, change 'python-pycrypto.inc' so that FILESEXTRAPATHS is prepended with the 'python-pycrypto' local dir for both versions instead of having that dir named after the package name '${PN}'. The python3 recipe is basically the same as for python2, but using distutils3 instead. Signed-off-by: Ricardo Silva <rjpdasilva@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
new file mode 100644
index 0000000000..02d634cb00
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pycrypto_2.6.1.bb
@@ -0,0 +1,9 @@
+inherit distutils3
+require python-pycrypto.inc
+
+# We explicitly call distutils_do_install, since we want it to run, but
+# *don't* want the autotools install to run, since this package doesn't
+# provide a "make install" target.
+do_install() {
+ distutils3_do_install
+}