aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-07-03 12:30:19 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-06 10:21:06 -0700
commite0a416a3adafd658f17ab5d47ddf51494f749294 (patch)
tree4aaab9818c73b0092dcd8dc48793c8c66c6a3d56 /meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.8.bb
parent0d624eac47a4d1e1740b84966cac828e00f9728c (diff)
downloadmeta-openembedded-contrib-e0a416a3adafd658f17ab5d47ddf51494f749294.tar.gz
python3-pyasn1-modules: Upgrade 0.2.7 -> 0.2.8
Upgrade to release 0.2.8: - Improve test routines for modules that use certificate extensions - Improve test for RFC3709 with a real world certificate - Added RFC7633 providing TLS Features Certificate Extension - Added RFC7229 providing OIDs for Test Certificate Policies - Added tests for RFC3280, RFC3281, RFC3852, and RFC4211 - Added RFC6960 providing Online Certificate Status Protocol (OCSP) - Added RFC6955 providing Diffie-Hellman Proof-of-Possession Algorithms - Updated the handling of maps for use with openType for RFC 3279 - Added RFC6486 providing RPKI Manifests - Added RFC6487 providing Profile for X.509 PKIX Resource Certificates - Added RFC6170 providing Certificate Image in the Internet X.509 Public Key Infrastructure, and import the object identifier into RFC3709. - Added RFC6187 providing Certificates for Secure Shell Authentication - Added RFC6482 providing RPKI Route Origin Authorizations (ROAs) - Added RFC6664 providing S/MIME Capabilities for Public Keys - Added RFC6120 providing Extensible Messaging and Presence Protocol names in certificates - Added RFC4985 providing Subject Alternative Name for expression of service names in certificates - Added RFC5924 providing Extended Key Usage for Session Initiation Protocol (SIP) in X.509 certificates - Added RFC5916 providing Device Owner Attribute - Added RFC7508 providing Securing Header Fields with S/MIME - Update RFC8226 to use ComponentPresentConstraint() instead of the previous work around - Add RFC2631 providing OtherInfo for Diffie-Hellman Key Agreement - Add RFC3114 providing test values for the S/MIME Security Label - Add RFC5755 providing Attribute Certificate Profile for Authorization - Add RFC5913 providing Clearance Attribute and Authority Clearance Constraints Certificate Extension - Add RFC5917 providing Clearance Sponsor Attribute - Add RFC4043 providing Internet X.509 PKI Permanent Identifier - Add RFC7585 providing Network Access Identifier (NAI) Realm Name for Certificates - Update RFC3770 to support openType for attributes and reported errata - Add RFC4334 providing Certificate Extensions and Attributes for Authentication in PPP and Wireless LAN Networks Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.8.bb b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.8.bb
new file mode 100644
index 0000000000..dd39e8c405
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pyasn1-modules_0.2.8.bb
@@ -0,0 +1,29 @@
+SUMMARY = "A collection of ASN.1-based protocols modules."
+DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\
+ classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\
+ data structures (X.509, PKCS etc.)."
+HOMEPAGE = "https://github.com/etingof/pyasn1-modules"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a14482d15c2249de3b6f0e8a47e021fd"
+
+SRC_URI[md5sum] = "107e1ece7d0a41d782f69f8a95a4d9bc"
+SRC_URI[sha256sum] = "905f84c712230b2c592c19470d3ca8d552de726050d1d1716282a1f6146be65e"
+
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN} = "${PYTHON_PN}-pyasn1"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}