aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-11 17:25:09 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-12 09:16:31 -0800
commitc168aa09f6cb712bb0667001af3ec8c468b05f8a (patch)
treede8b76c767ae6528d875edf349bec87dcd9ae771 /meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
parent1ca2f1235f5b7ff212e55f45546bcbc9dfa6042e (diff)
downloadmeta-openembedded-contrib-c168aa09f6cb712bb0667001af3ec8c468b05f8a.tar.gz
python3-ptyprocess: Upgrade 0.6.0 -> 0.7.0
Upgrade to release 0.7.0: - Add pass_fds parameters - Switch to Github actions for CI Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb b/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
new file mode 100644
index 0000000000..607c719461
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ptyprocess_0.7.0.bb
@@ -0,0 +1,42 @@
+SUMMARY = "Run a subprocess in a pseudo terminal"
+HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
+
+SRCNAME = "ptyprocess"
+
+SRC_URI[sha256sum] = "5c5d0a3b48ceee0b48485e0c26037c0acd7d29765ca3fbb5cb3831d347423220"
+
+inherit pypi setuptools3
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-resource \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+inherit ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-resource \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}