aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-13 11:59:13 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-15 11:42:15 -0700
commitc5210205e78da26da00ece18fafe4924a001ddfe (patch)
treeb752f44a9ec491d565a5b64def1f1cd56747e1f1 /meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
parent362d199bd15ac519190804d50c9998be41ce79db (diff)
downloadmeta-openembedded-contrib-c5210205e78da26da00ece18fafe4924a001ddfe.tar.gz
python3-prompt-toolkit: Upgrade 3.0.7 -> 3.0.8
Upgrade to release 3.0.8: - Added `validator` parameter to `input_dialog`. - Cope with stdout not having a working `fileno`. - Handle situation when /dev/null is piped into stdin, or when stdin is closed somehow. - Fix for telnet/ssh server: `isatty` method was not implemented. - Display correct error when a tuple is passed into `to_formatted_text`. - Pass along WORD parameter in `Document._is_word_before_cursor_complete`. Fixes some key bindings. - Expose `ProgressBarCounter` in shortcuts module. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
new file mode 100644
index 0000000000..0debba48d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.8.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Library for building powerful interactive command lines in Python"
+HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
+
+SRC_URI[md5sum] = "cf3ca19873fa9e7f6162296cf6bae419"
+SRC_URI[sha256sum] = "25c95d2ac813909f813c93fde734b6e44406d1477a9faef7c915ff37d39c0a8c"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "prompt_toolkit"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-six \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-wcwidth \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-image \
+"
+
+BBCLASSEXTEND = "native nativesdk"