aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-06-22 20:25:50 -0700
committerKhem Raj <raj.khem@gmail.com>2021-06-24 12:54:18 -0700
commit13fadb1d03085322d317fdcce22ba5bb22bbe76c (patch)
tree056aae850ed3613ed6fe2949389cc0ef5b5425cc /meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb
parent806bd77a505b37abe9c173cdd554cc6486406a35 (diff)
downloadmeta-openembedded-contrib-13fadb1d03085322d317fdcce22ba5bb22bbe76c.tar.gz
python3-process-tests: Add recipe
Needed by ptests of other modules Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb b/meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb
new file mode 100644
index 0000000000..dccdeb7a00
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-process-tests_2.1.2.bb
@@ -0,0 +1,15 @@
+# Copyright (C) 2021 Khem Raj <raj.khem@gmail.com>
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "Tools for testing processes."
+HOMEPAGE = "https://github.com/ionelmc/python-process-tests"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37031056aff37e4b3310872a9a3d0b1e"
+
+SRC_URI[sha256sum] = "a3747ad947bdfc93e5c986bdb17a6d718f3f26e8577a0807a00962f29e26deba"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-core"
+
+BBCLASSEXTEND = "native nativesdk"