aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2020-04-04 01:46:15 +0800
committerKhem Raj <raj.khem@gmail.com>2020-04-03 14:38:09 -0700
commit00e16173308d409acbe15cde261cc502017e2eca (patch)
treeafa8973979f74a0b9d9b1d0c1fab954d439b5131 /meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
parenta383dd710cc8e2d81a4377788c2bb6b31aee591b (diff)
downloadmeta-openembedded-contrib-00e16173308d409acbe15cde261cc502017e2eca.tar.gz
python3-precise-runner: Enable ptest
Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb b/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
index 98b62d899c..6155b79818 100644
--- a/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
+++ b/meta-python/recipes-devtools/python/python3-precise-runner_0.3.1.bb
@@ -6,4 +6,17 @@ LIC_FILES_CHKSUM = "file://README.md;md5=2ad29e930f3107d52d2a55728bf62116"
SRC_URI[md5sum] = "a2434be110444192e804f4dada0ccecf"
SRC_URI[sha256sum] = "1a464209fb4bf0a3f5d5a428310cb2a70487a01a6bc3a960d1dda90af896b80d"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
+}