aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-29 21:32:30 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-01 10:44:55 -0800
commit5fc34f7850e6ced6a4320a9a6da93800d162a22c (patch)
tree2de446bfd5e67c89cad947b4650c12b714eba91f /meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
parent59506ec90ea39230ff29e2c4e1f1be6419ff8796 (diff)
downloadmeta-openembedded-contrib-5fc34f7850e6ced6a4320a9a6da93800d162a22c.tar.gz
python3-prctl: Upgrade 1.7 -> 1.8.1
Upgrade to release 1.8.1: - Master was renamed to main - Backwards compatibility fixes - Install dependencies before trying to build/publish License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
new file mode 100644
index 0000000000..b87a470b40
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prctl_1.8.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Control process attributes through prctl"
+DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \
+process' behaviour. Usage of the function is fairly messy though, due to \
+limitations in C and linux. This module provides a nice non-messy python(ic) \
+interface."
+SECTION = "devel/python"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1475481f9ec754d758859bd2c75f6f6f"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "5e12e398eb5c4e30d7b29b02458c76d2cc780700"
+PV = "1.8.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/seveas/python-prctl;branch=main\
+ file://0001-support-cross-complication.patch \
+"
+inherit setuptools3 python3native
+
+DEPENDS += "libcap"
+