aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prctl_1.6.1.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-07-18 02:09:12 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-24 18:58:52 +0200
commitb344ce38db1f434b93bb981d3e4fc39144492ef1 (patch)
tree50a0ec4cd82c518b16524d5ca432a10528757876 /meta-python/recipes-devtools/python/python3-prctl_1.6.1.bb
parente81db0521ad7270846c1d0507caa4e4c0071e517 (diff)
downloadmeta-openembedded-contrib-b344ce38db1f434b93bb981d3e4fc39144492ef1.tar.gz
python3-prctl: add recipe 1.6.1
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prctl_1.6.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-prctl_1.6.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prctl_1.6.1.bb b/meta-python/recipes-devtools/python/python3-prctl_1.6.1.bb
new file mode 100644
index 0000000000..5de83ce487
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-prctl_1.6.1.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Control process attributes through prctl"
+DESCRIPTION = "The linux prctl function allows you to control specific characteristics of a \
+process' behaviour. Usage of the function is fairly messy though, due to \
+limitations in C and linux. This module provides a nice non-messy python(ic) \
+interface."
+SECTION = "devel/python"
+LICENSE = "GPLv3"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5eb2f4bcd60326f83e5deb542372d52f"
+
+S = "${WORKDIR}/git"
+B = "${S}"
+
+SRCREV = "1107d0be7bec4b28c85c62c454882d16844c930a"
+PV = "1.6.1+git${SRCPV}"
+
+SRC_URI = "git://github.com/seveas/python-prctl;branch=master \
+ file://0001-support-cross-complication.patch \
+"
+inherit setuptools3 python3native
+
+DEPENDS += "libcap"
+