aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-prctl
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-29 21:32:30 +0200
committerKhem Raj <raj.khem@gmail.com>2021-02-01 10:44:55 -0800
commit5fc34f7850e6ced6a4320a9a6da93800d162a22c (patch)
tree2de446bfd5e67c89cad947b4650c12b714eba91f /meta-python/recipes-devtools/python/python3-prctl
parent59506ec90ea39230ff29e2c4e1f1be6419ff8796 (diff)
downloadmeta-openembedded-contrib-5fc34f7850e6ced6a4320a9a6da93800d162a22c.tar.gz
python3-prctl: Upgrade 1.7 -> 1.8.1
Upgrade to release 1.8.1: - Master was renamed to main - Backwards compatibility fixes - Install dependencies before trying to build/publish License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-prctl')
-rw-r--r--meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch b/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch
index 775ae1b2e2..98d250c74c 100644
--- a/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch
+++ b/meta-python/recipes-devtools/python/python3-prctl/0001-support-cross-complication.patch
@@ -1,4 +1,4 @@
-From 9a16800738547d117284354bbcad7dd77d9d0344 Mon Sep 17 00:00:00 2001
+From 5f3911737c63a098caf73f1365320fe1b3a7638b Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Thu, 21 Apr 2016 03:05:57 -0400
Subject: [PATCH] support cross-complication
@@ -6,12 +6,13 @@ Subject: [PATCH] support cross-complication
Upstream-Status: Inappropriate [oe specific]
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
setup.py | 35 -----------------------------------
1 file changed, 35 deletions(-)
diff --git a/setup.py b/setup.py
-index 658d1a5..e8be7eb 100755
+index eb83cfe..3f9567b 100755
--- a/setup.py
+++ b/setup.py
@@ -13,41 +13,6 @@ import sys
@@ -38,13 +39,13 @@ index 658d1a5..e8be7eb 100755
- sys.stderr.write("You need to install gcc to build this module\n")
- sys.exit(1)
-
--sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
+-sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, env=os.environ)
-sp.communicate('#include <sys/prctl.h>\n'.encode())
-if sp.returncode:
- sys.stderr.write("You need to install libc development headers to build this module\n")
- exit = True
-
--sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
+-sp = subprocess.Popen(['cpp'], stdin=subprocess.PIPE, stdout=subprocess.PIPE, stderr=subprocess.PIPE, env=os.environ)
-sp.communicate('#include <sys/capability.h>\n'.encode())
-if sp.returncode:
- sys.stderr.write("You need to install libcap development headers to build this module\n")
@@ -57,5 +58,5 @@ index 658d1a5..e8be7eb 100755
sources = ['_prctlmodule.c'],
depends = ['securebits.h'],
--
-2.8.1
+2.17.1