aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-portion_2.1.6.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-04-19 10:57:26 +0300
committerKhem Raj <raj.khem@gmail.com>2021-04-21 08:26:07 -0700
commita2ebdf3fe3ecae5b2c8a286d08c55d92d388ef67 (patch)
tree45c82776b06ea507b7e2d5f39fa846f080b717ab /meta-python/recipes-devtools/python/python3-portion_2.1.6.bb
parentbd115de27f2147311899d90a135eddfad1ca3e3d (diff)
downloadmeta-openembedded-contrib-a2ebdf3fe3ecae5b2c8a286d08c55d92d388ef67.tar.gz
python3-portion: Upgrade 2.1.5 -> 2.1.6
Upgrade to release 2.1.6: - from_stringraises a ValueError if given string cannot be parsed to an interval - Drop official support for Python 3.5 - Use black as official code formatting Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-portion_2.1.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-portion_2.1.6.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-portion_2.1.6.bb b/meta-python/recipes-devtools/python/python3-portion_2.1.6.bb
new file mode 100644
index 0000000000..a1076f9f0c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-portion_2.1.6.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Python data structure and operations for intervals"
+HOMEPAGE = "https://github.com/AlexandreDecan/portion"
+SECTION = "devel/python"
+
+LICENSE = "LGPLv3"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05f1e16a8e59ce3e9a979e881816c2ab"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "725b65da806fb79df05c0b6383b01631c510f371d9bc0ece93a996b4260ba085"
+
+BBCLASSEXTEND = "native"