aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:38 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commit87980b86bcc3528f16550d790083a24ad29682a1 (patch)
treed094aabf64379eb0107c30a5fa0150b9479bb5a2 /meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
parent344d345139c5f646ad194cbf7296e2db73511274 (diff)
downloadmeta-openembedded-contrib-87980b86bcc3528f16550d790083a24ad29682a1.tar.gz
python3-polyline: add recipe for 1.4.0
Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
new file mode 100644
index 0000000000..3b3e2071f1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-polyline_1.4.0.bb
@@ -0,0 +1,13 @@
+SUMMARY = "A Python implementation of Google's Encoded Polyline Algorithm Format"
+HOMEPAGE = "https://pypi.org/project/polyline/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0fbd13500cabd06dd751ba6b2be304c6"
+
+SRC_URI[md5sum] = "b97c57378605c4a856c437569f95a0cb"
+SRC_URI[sha256sum] = "7c7f89d09a09c7b6161bdbfb4fd304b186fc7a2060fa4f31cb3f61c646a5c074"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-six"
+
+BBCLASSEXTEND = "native nativesdk"