aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pint_0.17.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-03-25 15:34:33 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-26 10:32:33 -0700
commitb433558aa03e352696eeed769b31ebae6520745a (patch)
tree91ece7bdf6347ea6e8bd116744c032f2d0c7133b /meta-python/recipes-devtools/python/python3-pint_0.17.bb
parenta028581d60352cb47057c9a1ae5971c90fe404a5 (diff)
downloadmeta-openembedded-contrib-b433558aa03e352696eeed769b31ebae6520745a.tar.gz
python3-pint: Upgrade 0.16.1 -> 0.17
Upgrade to release 0.17: - Add the Wh unit for battery capacity measurements - Fix issue with reducable dimensionless units when using power (Quantity**ndarray) - Fix comparisons between Quantities and Measurements. - UnitsContainer returns false if other is str and cannnot be parsed - Fix numpy.linalg.solve unit output. - Support numpy.lib.stride_tricks.sliding_window_view. - NEP29 Support docs. - Move all tests to pytest. - Fix to __pow__ and __ipow__ - Migrate to Github Actions. - Update linter to use pre-commit. - Quantity comparisons now ensure other is Quantity. - Add sign function compatibility. - Fix scalar to ndarray tolist. - Fix tolist function with scalar ndarray. - Corrected typos and dacstrings - Implements a first benchmark suite in airspeed velocity (asv). - Power for pseudo-dimensionless units. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pint_0.17.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.17.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.17.bb b/meta-python/recipes-devtools/python/python3-pint_0.17.bb
new file mode 100644
index 0000000000..9a474901e9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pint_0.17.bb
@@ -0,0 +1,35 @@
+SUMMARY = "Physical quantities module"
+DESCRIPTION = "Physical quantities Python module"
+HOMEPAGE = "https://github.com/hgrecco/pint"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi ptest setuptools3
+
+SRC_URI[sha256sum] = "f4d0caa713239e6847a7c6eefe2427358566451fe56497d533f21fb590a3f313"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-packaging \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}