aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pint_0.16.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-23 10:58:27 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-24 12:52:24 -0700
commit26b4a9aa6fd11e289aff2cbbfe1c1e7ce6c09320 (patch)
tree9a36442e54193cf4b293c6c931e76769c0e5a51e /meta-python/recipes-devtools/python/python3-pint_0.16.1.bb
parent69b2bca15e3b0adc314ddb3e2993df8f9f4038b5 (diff)
downloadmeta-openembedded-contrib-26b4a9aa6fd11e289aff2cbbfe1c1e7ce6c09320.tar.gz
python3-pint: Upgrade 0.16 -> 0.16.1
Upgrade to release 0.16.1: - Fix unpickling, now it is using the APP_REGISTRY as expected. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pint_0.16.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.16.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.16.1.bb b/meta-python/recipes-devtools/python/python3-pint_0.16.1.bb
new file mode 100644
index 0000000000..d96659592a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pint_0.16.1.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Physical quantities module"
+DESCRIPTION = "Physical quantities Python module"
+HOMEPAGE = "https://github.com/hgrecco/pint"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi ptest setuptools3
+
+SRC_URI[md5sum] = "d4a7bbdf505dee964eb1e5e6e7f80c34"
+SRC_URI[sha256sum] = "d43a2e9ae003164978b60fdf8cd920d8581e1a5991df8dded29b00f4850ec83a"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-packaging \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}