aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pint_0.15.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-24 12:14:55 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-25 10:33:51 -0700
commita4daf0d4681eb613a26201bfc5e908e4f42d5e6a (patch)
tree0ffbb87a1589470587936276b26013972e1372fe /meta-python/recipes-devtools/python/python3-pint_0.15.bb
parent969ccb7a5f15cc3ecc4f62285f0c0ae865da7e6f (diff)
downloadmeta-openembedded-contrib-a4daf0d4681eb613a26201bfc5e908e4f42d5e6a.tar.gz
python3-pint: Upgrade 0.14 -> 0.15
Upgrade to release 0.15: - Change `Quantity` and `Unit` HTML (i.e., Jupyter notebook) repr away from LaTeX to a simpler, more performant pretty-text and table based repr inspired by Sparse and Dask. - Add `case_sensitive` option to registry for case (in)sensitive handling when parsing units. - Implement Dask collection interface to support Pint Quantity wrapped Dask arrays. - Started automatically testing examples in the documentation - Fixed an exception generated when reducing dimensions with three or more units of the same type. - Fixed right operand power for dimensionless Quantity to reflect numpy behavior. - Eliminated warning when setting a masked value on an underlying MaskedArray. - Add `sort` option to `formatting.formatter` to permit disabling sorting of component units in format string. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pint_0.15.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pint_0.15.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pint_0.15.bb b/meta-python/recipes-devtools/python/python3-pint_0.15.bb
new file mode 100644
index 0000000000..4df5573b1d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pint_0.15.bb
@@ -0,0 +1,36 @@
+SUMMARY = "Physical quantities module"
+DESCRIPTION = "Physical quantities Python module"
+HOMEPAGE = "https://github.com/hgrecco/pint"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=bccf824202692270a1e0829a62e3f47b"
+
+PYPI_PACKAGE := "Pint"
+
+inherit pypi ptest setuptools3
+
+SRC_URI[md5sum] = "8171859d92713c13cd13ea7100a707f0"
+SRC_URI[sha256sum] = "73b517bc4e49d199eb8ae9ed49104d74a11e596849ad2330b58c09e1eb6f327d"
+
+DEPENDS += "python3-setuptools-scm-native"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-packaging \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/testsuite
+ cp -rf ${S}/pint/testsuite/* ${D}${PTEST_PATH}/testsuite/
+}