aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-11 17:25:03 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-12 09:16:03 -0800
commitae76da9210b51485da995b51f7ed41e89471dea9 (patch)
treedd9d2c61e1735b175474a71a91265b3da295aad5 /meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb
parent49d3d32fae5e253543974a5d90eab138bcfdfd01 (diff)
downloadmeta-openembedded-contrib-ae76da9210b51485da995b51f7ed41e89471dea9.tar.gz
python3-pillow: Upgrade 7.2.0 -> 8.1.0
Upgrade to release 8.1.0: - Fix TIFF OOB Write error - Fix for Buffer Read Overrun in PCX Decoding - Fix for SGI Decode buffer overrun - Fix OOB Read when saving GIF of xsize=1 - Add support for PySide6 - Moved QApplication into one test - Use disposal settings from previous frame in APNG - Revert "skip wheels on 3.10-dev due to wheel#354" - Better _binary module use - Added exception explaining that repr_png saves to PNG - Use previous disposal method in GIF load_end - Do not catch a ValueError only to raise another - Allow putpalette to accept 1024 integers to include alpha values - Fix OOB Read when writing TIFF with custom Metadata - Removed unused variable - Fix dereferencing of potential null pointers - Fixed warnings assigning to "unsigned char *" from "char *" - Add append_images support for ICO - Fixed comparison warnings - Block TIFFTAG_SUBIFD - Fix dereferencing potential null pointer - Replaced PyErr_NoMemory with ImagingError_MemoryError - Remove duplicate code - Moved warning to end of execution - Removed unused fromstring and tostring C methods - init() if one of the formats is unrecognised License-Update: Updated copyright year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb b/meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb
new file mode 100644
index 0000000000..63974590cc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pillow_8.1.0.bb
@@ -0,0 +1,37 @@
+SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
+Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
+Contributors."
+HOMEPAGE = "https://pillow.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0337b116233da4616ae9fdb130bf6f1a"
+
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=8.1.x \
+ file://0001-support-cross-compiling.patch \
+ file://0001-explicitly-set-compile-options.patch \
+"
+SRCREV ?= "fcc42e0d344146ee9d265d1f43c094ce5a0ec4cf"
+
+inherit setuptools3
+
+DEPENDS += " \
+ zlib \
+ jpeg \
+ tiff \
+ freetype \
+ lcms \
+ openjpeg \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+"
+
+CVE_PRODUCT = "pillow"
+
+S = "${WORKDIR}/git"
+
+RPROVIDES_${PN} += "python3-imaging"
+
+BBCLASSEXTEND = "native"