aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2019-10-29 11:16:21 +1300
committerKhem Raj <raj.khem@gmail.com>2019-10-28 23:48:27 -0700
commit29d6510134637a314b46185b2f34c17b7038b2e5 (patch)
treeb2d4a4de4d9b936f69e0d8c12c2ebae3c65e5f2a /meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
parentc986cbed9329aff1401acede425ffb0910512ad2 (diff)
downloadmeta-openembedded-contrib-29d6510134637a314b46185b2f34c17b7038b2e5.tar.gz
python3-pillow: update to 6.2.1
Upstream release notes: https://pillow.readthedocs.io/en/stable/releasenotes/6.2.0.html https://pillow.readthedocs.io/en/stable/releasenotes/6.2.1.html Also fixes CVE-2019-16865: https://nvd.nist.gov/vuln/detail/CVE-2019-16865 Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb b/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
new file mode 100644
index 0000000000..a383a3ff91
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb
@@ -0,0 +1,38 @@
+SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
+Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
+Contributors."
+HOMEPAGE = "https://pillow.readthedocs.io"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=55c0f320370091249c1755c0d2b48e89"
+
+SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=6.2.x \
+ file://0001-support-cross-compiling.patch \
+ file://0001-explicitly-set-compile-options.patch \
+"
+SRCREV ?= "6e0f07bbe38def22d36ee176b2efd9ea74b453a6"
+
+
+inherit setuptools3
+
+DEPENDS += " \
+ zlib \
+ jpeg \
+ tiff \
+ freetype \
+ lcms \
+ openjpeg \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-numbers \
+"
+
+CVE_PRODUCT = "pillow"
+
+S = "${WORKDIR}/git"
+
+RPROVIDES_${PN} += "python3-imaging"
+
+BBCLASSEXTEND = "native"