aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pillow
diff options
context:
space:
mode:
authorOvidiu Panait <ovidiu.panait@windriver.com>2019-07-15 10:38:43 +0300
committerKhem Raj <raj.khem@gmail.com>2019-07-15 08:00:06 -0700
commit066d5af9ceaba9c458fe98f4239731d32afc6ab7 (patch)
tree5797a7e8c67abf42718f0ab7563ef3f14e91e1db /meta-python/recipes-devtools/python/python3-pillow
parenta6784c888b11e950b16bf6dc4ff03a6d87400691 (diff)
downloadmeta-openembedded-contrib-066d5af9ceaba9c458fe98f4239731d32afc6ab7.tar.gz
python3-pillow: 5.4.1 -> 6.1
Update python3-pillow to version 6.1 and refresh patches. License-Update: copyright years Signed-off-by: Ovidiu Panait <ovidiu.panait@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pillow')
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch10
-rw-r--r--meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch32
2 files changed, 21 insertions, 21 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
index de89ba0058..d4372696fe 100644
--- a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
+++ b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch
@@ -1,4 +1,4 @@
-From 52879439f2976662140b76951f43f16e1d5ef08e Mon Sep 17 00:00:00 2001
+From 9f3073bf6a7c7c51bb49d25f65c8f75cc704a5ee Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Mon, 18 Mar 2019 23:23:55 -0400
Subject: [PATCH] explicitly set compile options
@@ -15,12 +15,12 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
1 file changed, 12 insertions(+)
diff --git a/setup.cfg b/setup.cfg
-index 95900ff..27da313 100644
+index 3ab2e127..e92615f3 100644
--- a/setup.cfg
+++ b/setup.cfg
-@@ -9,3 +9,15 @@ addopts = -vx Tests
-
+@@ -4,3 +4,15 @@ test=pytest
[flake8]
+ extend-ignore = E203, W503
max-line-length = 88
+
+[build_ext]
@@ -35,5 +35,5 @@ index 95900ff..27da313 100644
+disable-webpmux = 1
+disable-imagequant = 1
--
-2.8.1
+2.20.1
diff --git a/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch b/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch
index e86293421c..6de19ad87a 100644
--- a/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch
+++ b/meta-python/recipes-devtools/python/python3-pillow/0001-support-cross-compiling.patch
@@ -1,4 +1,4 @@
-From a78411402c824668283beb94db4bf7e206a4cf60 Mon Sep 17 00:00:00 2001
+From ae7c8d0336381dd4c10e809e9c8926f9deeafeb8 Mon Sep 17 00:00:00 2001
From: Hongxu Jia <hongxu.jia@windriver.com>
Date: Thu, 14 Mar 2019 03:48:10 -0400
Subject: [PATCH] support cross compiling
@@ -11,29 +11,29 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
1 file changed, 3 insertions(+), 10 deletions(-)
diff --git a/setup.py b/setup.py
-index 79f912b..37e5827 100755
+index 5ceae344..07863340 100755
--- a/setup.py
+++ b/setup.py
-@@ -50,7 +50,7 @@ _LIB_IMAGING = (
- "ZipEncode", "TiffDecode", "Jpeg2KDecode", "Jpeg2KEncode", "BoxBlur",
- "QuantPngQuant", "codec_fd")
+@@ -105,7 +105,7 @@ _LIB_IMAGING = (
+ "codec_fd",
+ )
-DEBUG = False
+DEBUG = True
class DependencyException(Exception):
-@@ -345,21 +345,16 @@ class pil_build_ext(build_ext):
+@@ -396,21 +396,16 @@ class pil_build_ext(build_ext):
_add_directory(library_dirs, match.group(1))
# include, rpath, if set as environment variables:
-- for k in ('C_INCLUDE_PATH', 'CPATH', 'INCLUDE'):
+- for k in ("C_INCLUDE_PATH", "CPATH", "INCLUDE"):
+ for k in ('C_INCLUDE_PATH', 'CPATH', 'INCLUDE', 'STAGING_INCDIR'):
if k in os.environ:
for d in os.environ[k].split(os.path.pathsep):
_add_directory(include_dirs, d)
-- for k in ('LD_RUN_PATH', 'LIBRARY_PATH', 'LIB'):
+- for k in ("LD_RUN_PATH", "LIBRARY_PATH", "LIB"):
+ for k in ('LD_RUN_PATH', 'LIBRARY_PATH', 'LIB', 'STAGING_LIBDIR'):
if k in os.environ:
for d in os.environ[k].split(os.path.pathsep):
@@ -47,15 +47,15 @@ index 79f912b..37e5827 100755
#
# add platform directories
-@@ -413,8 +408,6 @@ class pil_build_ext(build_ext):
- elif sys.platform.startswith("linux") or \
- sys.platform.startswith("gnu") or \
- sys.platform.startswith("freebsd"):
+@@ -469,8 +464,6 @@ class pil_build_ext(build_ext):
+ or sys.platform.startswith("gnu")
+ or sys.platform.startswith("freebsd")
+ ):
- for dirname in _find_library_dirs_ldconfig():
- _add_directory(library_dirs, dirname)
- if sys.platform.startswith("linux") and \
- os.environ.get('ANDROID_ROOT', None):
- # termux support for android.
+ if sys.platform.startswith("linux") and os.environ.get(
+ "ANDROID_ROOT", None
+ ):
--
-2.8.1
+2.20.1