aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-parso_0.8.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-10 17:43:12 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-11 09:41:56 -0700
commiteac82d1bbeb147f51b383acf3d07deb4f8449b15 (patch)
tree46b976c0a5f8d1d54a0802b14ec1534bf21919cf /meta-python/recipes-devtools/python/python3-parso_0.8.0.bb
parent02608610043b200764b7ec743acfe3af71a7024d (diff)
downloadmeta-openembedded-contrib-eac82d1bbeb147f51b383acf3d07deb4f8449b15.tar.gz
python3-parso: Upgrade 0.7.1 -> 0.8.0
Upgrade to release 0.8.0: - Dropped Support for Python 2.7, 3.4, 3.5 - It's possible to use ``pathlib.Path`` objects now in the API - The stubs are gone, we are now using annotations - ``namedexpr_test`` nodes are now a proper class called ``NamedExpr`` - A lot of smaller refactorings Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-parso_0.8.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-parso_0.8.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parso_0.8.0.bb b/meta-python/recipes-devtools/python/python3-parso_0.8.0.bb
new file mode 100644
index 0000000000..507087909e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-parso_0.8.0.bb
@@ -0,0 +1,12 @@
+SUMMARY = "A Python Parser"
+HOMEPAGE = "https://github.com/davidhalter/parso"
+AUTHOR = "David Halter <davidhalter88@gmail.com>"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbaa2675b2424d771451332a7a69503f"
+
+PYPI_PACKAGE = "parso"
+
+SRC_URI[md5sum] = "ee3592994bfc0d0843790544c1b2b702"
+SRC_URI[sha256sum] = "2b6db14759c528d857eeb9eac559c2166b2554548af39f5198bdfb976f72aa64"
+
+inherit setuptools3 pypi