aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-parse_1.18.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-14 16:15:36 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-15 09:28:35 -0700
commitb6870570cff47720c7421820e18d9a10977723a6 (patch)
treedafb43ff878c8637645750eb822b04c411c5e847 /meta-python/recipes-devtools/python/python3-parse_1.18.0.bb
parente926680b8dd027273088c7889742a22592209ae2 (diff)
downloadmeta-openembedded-contrib-b6870570cff47720c7421820e18d9a10977723a6.tar.gz
python3-parse: Upgrade 1.17.0 -> 1.18.0
Upgrade to release 1.18.0: - Correct bug in int parsing introduced in 1.16.0 Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-parse_1.18.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse_1.18.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse_1.18.0.bb b/meta-python/recipes-devtools/python/python3-parse_1.18.0.bb
new file mode 100644
index 0000000000..ed9204e3bc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-parse_1.18.0.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Parse strings using a specification based on the Python format() syntax"
+HOMEPAGE = "https://github.com/r1chardj0n3s/parse"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8ab458ad281b60e6f1b39b3feafbfc05"
+
+SRC_URI[md5sum] = "42ea0002cf36bfd2bd74f3c05bf25f60"
+SRC_URI[sha256sum] = "91666032d6723dc5905248417ef0dc9e4c51df9526aaeef271eacad6491f06a4"
+
+inherit pypi setuptools3 ptest
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-logging \
+ "
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_parse.py ${D}${PTEST_PATH}/
+}