aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-12 12:47:57 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-13 21:34:21 -0700
commit34c8d65498f1dfa8af11bc023557052b7ff09aab (patch)
tree5826dea03cc1df4a9140bf7cdd8cf8301cb8e9b7 /meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
parent180688cf301f2d045ad22ae9bd8d706476e50554 (diff)
downloadmeta-openembedded-contrib-34c8d65498f1dfa8af11bc023557052b7ff09aab.tar.gz
python3-parse-type: Upgrade 0.4.2 -> 0.5.2
Upgrade to release 0.5.2. The year in file LICENCE has been changed therefore the checksum has been changed but it still remains a BSD License. Add python3-six as a run-time dependency. The new release brings: - Update to parse-1.12.0 - Code cleanups - Bug fixes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb b/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
new file mode 100644
index 0000000000..f61c480bdd
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Simplifies building parse types based on the parse module"
+HOMEPAGE = "https://github.com/jenisys/parse_type"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=16374dbaeaca1890153edb3f41371222"
+
+SRC_URI[md5sum] = "b954062f14ab723a91fe1e2be15e859d"
+SRC_URI[sha256sum] = "7f690b18d35048c15438d6d0571f9045cffbec5907e0b1ccf006f889e3a38c0b"
+
+PYPI_PACKAGE = "parse_type"
+inherit pypi ptest setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-parse ${PYTHON_PN}-six"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}