aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pandas_1.0.5.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-25 12:07:15 +0300
committerArmin Kuster <akuster808@gmail.com>2020-08-27 15:40:21 -0700
commitfd16ab3d6484994eb1e285f0fd34ad3a5de38301 (patch)
tree205bdb3ac49a27688ea2416cdf2f921275fe27b1 /meta-python/recipes-devtools/python/python3-pandas_1.0.5.bb
parent0bc6614b1aed4c01d1970b025741cc71309f90f1 (diff)
downloadmeta-openembedded-contrib-fd16ab3d6484994eb1e285f0fd34ad3a5de38301.tar.gz
python3-pandas: Upgrade 1.0.3 -> 1.0.5
Upgrade to release 1.0.5: - Fix regression in read_parquet() when reading from file-like objects. - Fix regression in reading from public S3 buckets. - Fixed regression in replace() raising an AssertionError when replacing values in an extension dtype with values of a different dtype Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 5dbc25ea9d4bd4b3f9a150d3893a12b41dd456d3) [ak: fixes build issue on CentOS7: Bug fix only update https://github.com/pandas-dev/pandas/releases] Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pandas_1.0.5.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_1.0.5.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.0.5.bb b/meta-python/recipes-devtools/python/python3-pandas_1.0.5.bb
new file mode 100644
index 0000000000..d8db4cef39
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pandas_1.0.5.bb
@@ -0,0 +1,23 @@
+SUMMARY = "pandas library for high-performance data analysis tools"
+DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
+high-performance, easy-to-use data structures and data analysis tools for \
+the Python programming language."
+HOMEPAGE = "http://pandas.pydata.org/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ee0470f2de336c370a71c2f8d5e81c11"
+
+SRC_URI[md5sum] = "5183db713194e6fbc96c45f30a0d1311"
+SRC_URI[sha256sum] = "69c5d920a0b2a9838e677f78f4dde506b95ea8e4d30da25859db6469ded84fa8"
+
+inherit pypi setuptools3
+
+DEPENDS += " \
+ ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-numpy \
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-pytz \
+"