aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ordered-set_3.0.0.bb
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2018-06-26 14:00:48 +0800
committerKhem Raj <raj.khem@gmail.com>2018-06-27 22:17:33 -0700
commitc8cec047811dfdaae82d9e7b892ef4f041f65a92 (patch)
tree2bc7fdf766b6cc4aaf327000df773b485f2fcc47 /meta-python/recipes-devtools/python/python3-ordered-set_3.0.0.bb
parent958d24047e1cfbd932e9be3cf459349b7c471ce7 (diff)
downloadmeta-openembedded-contrib-c8cec047811dfdaae82d9e7b892ef4f041f65a92.tar.gz
python3-ordered-set: upgrade 2.0.2 -> 3.0.0
The license checksum changes but the license remains the same. The change is just about year, 2013 -> 2018. Add python3-pytest-runner to DEPENDS to solve the following error. | distutils.errors.DistutilsError: Could not find suitable distribution \ for Requirement.parse('pytest-runner') Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ordered-set_3.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ordered-set_3.0.0.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ordered-set_3.0.0.bb b/meta-python/recipes-devtools/python/python3-ordered-set_3.0.0.bb
new file mode 100644
index 0000000000..b731c28d2d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ordered-set_3.0.0.bb
@@ -0,0 +1,11 @@
+SUMMARY = "A MutableSet that remembers its order, so that every entry has an index."
+HOMEPAGE = "http://github.com/LuminosoInsight/ordered-set"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://MIT-LICENSE;md5=2b36be0d99854aa2ae292a800a7c1d4e"
+
+SRC_URI[md5sum] = "c8f5b99b717618803b914dd9cfe5ef43"
+SRC_URI[sha256sum] = "a34399fe6aa78358aaa00129d67c65b4aa099adfc023731b1d756c85776a89bb"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-pytest-runner-native"