aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-oauthlib_3.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-09 12:11:21 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-10 20:55:46 -0700
commit5b78352bc26ce696714c00d04b7242228dc5804b (patch)
tree7fe8948f7ae62ef5235d8439754b0ac278f8e634 /meta-python/recipes-devtools/python/python3-oauthlib_3.1.0.bb
parente9c1bb5b7c75b3e3829706cacdf2869a9497f0cd (diff)
downloadmeta-openembedded-contrib-5b78352bc26ce696714c00d04b7242228dc5804b.tar.gz
python3-oauthlib: Upgrade 2.0.6 -> 3.1.0
Upgrade to release 3.1.0. The year in file LICENCE has been updated therefore the checksum has been changed but it still remains a BSD license. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-oauthlib_3.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-oauthlib_3.1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-oauthlib_3.1.0.bb b/meta-python/recipes-devtools/python/python3-oauthlib_3.1.0.bb
new file mode 100644
index 0000000000..fe27e8e505
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-oauthlib_3.1.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "A generic, spec-compliant, thorough implementation of the OAuth request-signing logic"
+HOMEPAGE = "https://github.com/idan/oauthlib"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=abd2675e944a2011aed7e505290ba482"
+
+SRC_URI[md5sum] = "43cb2b5bac983712ee55076b61181cc2"
+SRC_URI[sha256sum] = "bee41cc35fcca6e988463cacc3bcb8a96224f470ca547e697b604cc697b2f889"
+
+inherit pypi setuptools3
+
+# The following configs & dependencies are from setuptools extras_require.
+# These dependencies are optional, hence can be controlled via PACKAGECONFIG.
+# The upstream names may not correspond exactly to bitbake package names.
+#
+# Uncomment this line to enable all the optional features.
+#PACKAGECONFIG ?= "test signedtoken signals rsa"
+PACKAGECONFIG[test] = ",,,${PYTHON_PN}-blinker ${PYTHON_PN}-cryptography ${PYTHON_PN}-nose ${PYTHON_PN}-pyjwt"
+PACKAGECONFIG[signedtoken] = ",,,${PYTHON_PN}-cryptography ${PYTHON_PN}-pyjwt"
+PACKAGECONFIG[signals] = ",,,${PYTHON_PN}-blinker"
+PACKAGECONFIG[rsa] = ",,,${PYTHON_PN}-cryptography"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-core ${PYTHON_PN}-crypt ${PYTHON_PN}-datetime ${PYTHON_PN}-json ${PYTHON_PN}-logging ${PYTHON_PN}-math ${PYTHON_PN}-netclient ${PYTHON_PN}-unittest"