aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-09-02 14:28:04 +0300
committerKhem Raj <raj.khem@gmail.com>2020-09-05 13:04:16 -0700
commit03431fe0a422e6ab1ba9f92a63313c96ca2eb2ca (patch)
tree28b5eaf25dd4157e50d245a4f434dd55782527b1 /meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb
parentc563a70087918b51b8e94d69894ec7897d55432a (diff)
downloadmeta-openembedded-contrib-03431fe0a422e6ab1ba9f92a63313c96ca2eb2ca.tar.gz
python3-nmap: Upgrade 1.4.7 -> 1.4.8
Upgrade to release 1.4.8: - Using of -Pn -sZ options for basic stealth scan - Refactoring nmap3.py to avoid repetitive code - Support for nmap stealth scans - Fix handling of xml.etree.ElementTree.Element with no sub elements - Support for gettings nmap raw outout Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb b/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb
new file mode 100644
index 0000000000..2037d496a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-nmap_1.4.8.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "python-nmap is a python library which helps in using nmap port scanner"
+HOMEPAGE = "https://www.nmmapper.com/"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+DEPENDS += "${PYTHON_PN}-wheel-native"
+
+PYPI_PACKAGE = "python3-nmap"
+
+SRC_URI[md5sum] = "e7904b39b64a8a44f275388862659a0d"
+SRC_URI[sha256sum] = "8d7da78142bee665289a243f71c5f48407d8ab7e5a02ee672ded05f339044759"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "nmap ${PYTHON_PN}-requests"