aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-24 18:16:23 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-25 10:22:28 -0700
commit0c9afaa6311b44a504792fd028f67f13af48fb8c (patch)
tree2e033c7ad5673bffd57fd7733a3a53087b91070d /meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
parentd143a976e43e37cd6219e50342349e76ca3c1672 (diff)
downloadmeta-openembedded-contrib-0c9afaa6311b44a504792fd028f67f13af48fb8c.tar.gz
python3-ndg-httpsclient: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Fix the HOMEPAGE to point to the GitHub repository. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb27
1 files changed, 26 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
index 65a8c816f4..23e1868c22 100644
--- a/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ndg-httpsclient_0.5.1.bb
@@ -1,5 +1,30 @@
+DESCRIPTION = "Provides enhanced HTTPS support for httplib and urllib2 using PyOpenSSL"
+HOMEPAGE = "https://github.com/cedadev/ndg_httpsclient/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://MANIFEST.in;md5=ce22c0cd986d2de3f7073cd6b5523ae0"
+
+SRC_URI[md5sum] = "b0fc8ea38f87d2c1ab1ed79a95c078f9"
+SRC_URI[sha256sum] = "d72faed0376ab039736c2ba12e30695e2788c4aa569c9c3e3d72131de2592210"
+
inherit pypi setuptools3 update-alternatives
-require python-ndg-httpsclient.inc
+
+PYPI_PACKAGE = "ndg_httpsclient"
+
+DEPENDS += " \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pyasn1 \
+"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-pyasn1 \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+UPSTREAM_CHECK_REGEX = ""
ALTERNATIVE_${PN} = "ndg_httpclient"
ALTERNATIVE_LINK_NAME[ndg_httpclient] = "${bindir}/ndg_httpclient"