aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-05 17:16:32 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-08 08:41:19 -0800
commit783897c53e271717dd8d87b7cbea042cea56e727 (patch)
treed81e774b07274524274e1a4364af50422377ec53 /meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb
parentb5cba105cc60638fd531ff30b5065888ec226bfa (diff)
downloadmeta-openembedded-contrib-783897c53e271717dd8d87b7cbea042cea56e727.tar.gz
python3-multidict: Upgrade 5.0.0 -> 5.1.0
Upgrade to release 5.1.0: - Support GenericAliases (MultiDict[str]) for Python 3.9+ - Synchronize the declared supported Python versions in setup.py with actually supported and tested ones. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb b/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb
new file mode 100644
index 0000000000..b960affac4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict_5.1.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
+HOMEPAGE = "https://github.com/aio-libs/multidict/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
+
+SRC_URI[sha256sum] = "25b4e5f22d3a37ddf3effc0710ba692cfc792c2b9edfb9c05aefe823256e84d5"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"