aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-12 17:00:20 +0300
committerKhem Raj <raj.khem@gmail.com>2020-10-13 22:28:52 -0700
commit8bc833a6bcd0b4637eca5631e2ffaa170654e9fc (patch)
treec28d857199a27492d492207f4dff01e2beda99d2 /meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb
parent65afded948a7ec2c8166214af799f63c17ce60e6 (diff)
downloadmeta-openembedded-contrib-8bc833a6bcd0b4637eca5631e2ffaa170654e9fc.tar.gz
python3-multidict: Upgrade 4.7.6 -> 5.0.0
Upgrade to release 5.0.0: - Provide wheels for aarch64, i686, ppc64le, s390x architectures on Linux as well as x86_64. - Provide wheels for Python 3.9. - Drop Python 3.5 support; Python 3.6 is the minimum supported Python version. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb b/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb
new file mode 100644
index 0000000000..676fbae7ed
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict_5.0.0.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
+HOMEPAGE = "https://github.com/aio-libs/multidict/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
+
+SRC_URI[md5sum] = "c2c3311e25636a6f213e998cd1e80d72"
+SRC_URI[sha256sum] = "1b324444299c3a49b601b1bf621fc21704e29066f6ac2b7d7e4034a4a18662a1"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"