aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-multidict_4.7.6.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-10 16:15:36 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-11 07:43:36 -0700
commit257a2f7afb51d9dfd0193c3ee41bc0e6d3211f89 (patch)
tree1b757273d2c2a99882cf31767bb214c12c8169fa /meta-python/recipes-devtools/python/python3-multidict_4.7.6.bb
parent58b2f2fe4d140fa49b576faad68274a363cdb7c6 (diff)
downloadmeta-openembedded-contrib-257a2f7afb51d9dfd0193c3ee41bc0e6d3211f89.tar.gz
python3-multidict: Upgrade 4.7.5 -> 4.7.6
Upgrade to release 4.7.6 which include the following bug fixes: * Fixed an issue with some versions of the wheel dist failing because of being unable to detect the license file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-multidict_4.7.6.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-multidict_4.7.6.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict_4.7.6.bb b/meta-python/recipes-devtools/python/python3-multidict_4.7.6.bb
new file mode 100644
index 0000000000..02c541b4c2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-multidict_4.7.6.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Multidicts are useful for working with HTTP headers, URL query args etc."
+HOMEPAGE = "https://github.com/aio-libs/multidict/"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a"
+
+SRC_URI[md5sum] = "40b6ca77171ac8af55f7aa60049f3cdf"
+SRC_URI[sha256sum] = "fbb77a75e529021e7c4a8d4e823d88ef4d23674a202be4f5addffc72cbb91430"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}
+
+BBCLASSEXTEND = "native nativesdk"