aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-11 17:25:12 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-12 09:16:44 -0800
commitfad349f0091f4553884b24ff7514352f904dead7 (patch)
treea8685fb2bc2ddde479e56da6eb339c63dcac2754 /meta-python/recipes-devtools/python/python3-mock_4.0.3.bb
parentf03a3313c350885044efdfd20bddd6af0cb1b2ef (diff)
downloadmeta-openembedded-contrib-fad349f0091f4553884b24ff7514352f904dead7.tar.gz
python3-mock: Upgrade 4.0.2 -> 4.0.3
Upgrade to release 4.0.3: - Remove unexpected call of __bool__ when passing a spec_arg argument to a Mock. - Revert bpo-25597. unittest.mock.MagicMock with wraps’ set uses default return values for magic methods. - Mock objects which are not unsafe will now raise an AttributeError if an attribute with the prefix asert, aseert, or assrt is accessed, in addition to this already happening for the prefixes assert or assret. - Fixed reverting multiple patches in unittest.mock. Patcher’s __exit__() is now never called if its __enter__() is failed. Returning true from __exit__() silences now the exception. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-mock_4.0.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-mock_4.0.3.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb b/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb
new file mode 100644
index 0000000000..b34f25b93d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-mock_4.0.3.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "A Python Mocking and Patching Library for Testing"
+HOMEPAGE = "https://pypi.python.org/pypi/mock"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=de9dfbf780446b18aab11f00baaf5b7e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "${PYTHON_PN}-prettytable \
+ ${PYTHON_PN}-cmd2 \
+ ${PYTHON_PN}-pyparsing \
+ ${PYTHON_PN}-mccabe \
+ ${PYTHON_PN}-pep8 \
+ ${PYTHON_PN}-pyflakes"
+
+SRC_URI[sha256sum] = "7d3fbbde18228f4ff2f1f119a45cdffa458b4c0dee32eb4d2bb2f82554bac7bc"