aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
diff options
context:
space:
mode:
authornick83ola <nick83ola@gmail.com>2020-03-25 06:22:09 +0000
committerKhem Raj <raj.khem@gmail.com>2020-03-25 06:52:29 -0700
commitcfa5f568901c41c8232c1d612ac53d176a537564 (patch)
tree84c76f3ee795cce944cff00508605e45db7c6f6b /meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
parentc6fb8e3efbb14d138a3aee6cf31e6ae96d57b54f (diff)
downloadmeta-openembedded-contrib-cfa5f568901c41c8232c1d612ac53d176a537564.tar.gz
python3-matplotlib: update to version 3.2.1
Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
new file mode 100644
index 0000000000..f6d8c53d05
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.2.1.bb
@@ -0,0 +1,37 @@
+SUMMARY = "matplotlib: plotting with Python"
+DESCRIPTION = "\
+Matplotlib is a Python 2D plotting library which produces \
+publication-quality figures in a variety of hardcopy formats \
+and interactive environments across platforms."
+HOMEPAGE = "https://github.com/matplotlib/matplotlib"
+SECTION = "devel/python"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "\
+ file://setup.py;beginline=250;endline=250;md5=2a114620e4e6843aa7568d5902501753 \
+ file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
+"
+DEPENDS = "\
+ freetype \
+ libpng \
+ python3-numpy-native \
+ python3-dateutil-native \
+ python3-pytz-native \
+"
+
+SRC_URI[md5sum] = "6c018a644a88120886cc7211f7c826f0"
+SRC_URI[sha256sum] = "ffe2f9cdcea1086fc414e82f42271ecf1976700b8edd16ca9d376189c6d93aee"
+
+inherit pypi setuptools3 pkgconfig
+
+RDEPENDS_${PN} = "\
+ freetype \
+ libpng \
+ python3-numpy \
+ python3-pyparsing \
+ python3-cycler \
+ python3-dateutil \
+ python3-kiwisolver \
+ python3-pytz \
+"
+
+BBCLASSEXTEND = "native"