aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-marshmallow_3.17.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2022-07-07 12:46:50 +0300
committerKhem Raj <raj.khem@gmail.com>2022-07-07 08:24:26 -0700
commitfffefa861a1a0fd388f726b23034f0668826f18b (patch)
tree56337638ecb35fcd0dff4c949332c8a458ca2b89 /meta-python/recipes-devtools/python/python3-marshmallow_3.17.0.bb
parentbc6374e53f9d20d3821c3ed8918c791070af9459 (diff)
downloadmeta-openembedded-contrib-fffefa861a1a0fd388f726b23034f0668826f18b.tar.gz
python3-marshmallow: Upgrade 3.15.0 -> 3.17.0
Upgrade to release 3.17.0: - Support serialization as float in TimeDelta field - Add messages_dict property to ValidationError to facilitate type checking Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-marshmallow_3.17.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-marshmallow_3.17.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.17.0.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.17.0.bb
new file mode 100644
index 0000000000..f2f5281d6c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.17.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Simplified object serialization in python"
+DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes."
+AUTHOR = "Marius Kriegerowski <mk@quakesaver.net>"
+HOMEPAGE = "https://github.com/marshmallow-code/marshmallow"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "\
+ file://LICENSE;md5=5bccd400dedfa74364481e56aacc0b4a \
+ file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb"
+
+SRC_URI = "git://github.com/marshmallow-code/marshmallow.git;protocol=https;branch=dev"
+
+SRCREV = "4a6c08d53f181195c78b505abe155b2f35cbc0c1"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+PIP_INSTALL_PACKAGE = "marshmallow"
+
+RDEPENDS:${PN} += " \
+ python3-core \
+ python3-datetime \
+ python3-netclient \
+ python3-numbers \
+ python3-json \
+ python3-pprint \
+ python3-packaging \
+"