aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-lz4_3.1.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-13 16:26:18 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-14 11:58:22 -0800
commit9da01fe4d407a6508794784da3b6bd0d1f870d5e (patch)
tree6420a8e01ac20ac5b8204131d65987e10369fe2f /meta-python/recipes-devtools/python/python3-lz4_3.1.1.bb
parent5211e51d43350433f7e7cb4eee9ea2decf2d2f8c (diff)
downloadmeta-openembedded-contrib-9da01fe4d407a6508794784da3b6bd0d1f870d5e.tar.gz
python3-lz4: Upgrade 3.1.0 -> 3.1.1
Upgrade to release 3.1.1: - Correct how pkgconfig is handled in setup.py to account for multiple build flags - Improve how CHAR_BIT is handled Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lz4_3.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-lz4_3.1.1.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lz4_3.1.1.bb b/meta-python/recipes-devtools/python/python3-lz4_3.1.1.bb
new file mode 100644
index 0000000000..1cc378def4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lz4_3.1.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "python bindings for the lz4 compression library by Yann Collet"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native \
+ ${PYTHON_PN}-pkgconfig-native \
+"
+
+SRC_URI[sha256sum] = "1ac354804cb2d5fb3d213857a6bf8590a301ef051cc16fbb4938bd2d6e524bda"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"