aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-lz4_3.1.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-29 20:18:53 +0300
committerKhem Raj <raj.khem@gmail.com>2020-07-03 18:06:56 -0700
commit19648e72f814feade99afcf971142a4dc047a7ac (patch)
tree50f0c54ddb35362d83f364eba9b1cdf798459ac3 /meta-python/recipes-devtools/python/python3-lz4_3.1.0.bb
parent11830057f445ed6643b9c9d6f4ce38aa76ad1043 (diff)
downloadmeta-openembedded-contrib-19648e72f814feade99afcf971142a4dc047a7ac.tar.gz
python3-lz4: Upgrade 3.0.2 -> 3.1.0
Upgrade to 3.1.0: - Adds block size record support to the stream bindings - Fixups to the tests to reduce execution time - A few small fixes Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lz4_3.1.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-lz4_3.1.0.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lz4_3.1.0.bb b/meta-python/recipes-devtools/python/python3-lz4_3.1.0.bb
new file mode 100644
index 0000000000..06bf631591
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-lz4_3.1.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "python bindings for the lz4 compression library by Yann Collet"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
+
+DEPENDS += " \
+ ${PYTHON_PN}-setuptools-scm-native \
+ ${PYTHON_PN}-pkgconfig-native \
+"
+
+SRC_URI[md5sum] = "1bf913acec3cb63893f522c222c8e3b1"
+SRC_URI[sha256sum] = "debe75513db3eb9e5cdcd82a329ff38374b6316ab65b848b571e0404746c1e05"
+
+inherit pypi setuptools3
+
+BBCLASSEXTEND = "native nativesdk"