aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-luma-core_2.2.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-12-18 23:47:48 +0200
committerKhem Raj <raj.khem@gmail.com>2020-12-21 17:53:38 -0800
commitf0b1671175493cd94cbbd79b3c1a7f5c576893f2 (patch)
treea878182ac3bb560913a6d799133230e79b1c3c83 /meta-python/recipes-devtools/python/python3-luma-core_2.2.0.bb
parent7e0fb6f8c55330cba44e2d603d1419a9751c71ee (diff)
downloadmeta-openembedded-contrib-f0b1671175493cd94cbbd79b3c1a7f5c576893f2.tar.gz
python3-luma-core: Upgrade 2.0.1 -> 2.2.0
Upgrade to release 2.2.0: - Linux framebuffer: Support BGR, RGBA & BGRA colorspace displays - Linux framebuffer pseudo-device uses diff-to-previous algorithm - Change order of namepaces cmdline, so SSD1306 is default Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-luma-core_2.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-luma-core_2.2.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-luma-core_2.2.0.bb b/meta-python/recipes-devtools/python/python3-luma-core_2.2.0.bb
new file mode 100644
index 0000000000..b181e09861
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-luma-core_2.2.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A component library to support SBC display drivers"
+DESCRIPTION = "A component library to support SBC display drivers"
+HOMEPAGE = "https://github.com/rm-hull/luma.core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=db07e3d471938ea7d7fd2135f88ac9a1"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "62a24518d3aa084d75206a19056eb8aa71b5a3d0c159d2e95b388cb3150a7b1c"
+
+CLEANBROKEN = "1"
+
+PYPI_PACKAGE = "luma.core"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pillow \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-smbus2 \
+"