aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-06-16 12:34:06 +0300
committerKhem Raj <raj.khem@gmail.com>2021-06-18 08:29:04 -0700
commitbddc712a127dfbafece7c85b73543b78506969fd (patch)
tree9e27e93090cc79afa60343cc0032a708ee5b5ac3 /meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
parentd0bedfca0c47e0d19352dd2133ace9270adfaa78 (diff)
downloadmeta-openembedded-contrib-bddc712a127dfbafece7c85b73543b78506969fd.tar.gz
python3-license-expression: Upgrade 1.2 -> 21.6.14
Upgrade to release 21.6.14: - Switch to calver for package versioning to better convey the currency of the bundled data. - Include https://scancode-licensedb.aboutcode.org/ licenses list with ScanCode (v21.6.7) and SPDX licenses (v3.13) keys. Add new functions to create Licensing using these licenses as LicenseSymbol. - Add new License.dedup() method to deduplicate and simplify license expressions without over simplifying. - Add new License.validate() method to return a new ExpressionInfo object with details on a license expression validation. - Drop support for Python 2. - Adopt the project skeleton from https://github.com/nexB/skeleton and its new configure script License-Update: Adopt latest skeleton, license remains the same. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb b/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
new file mode 100644
index 0000000000..0513d091f9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-license-expression_21.6.14.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
+HOMEPAGE = "https://github.com/nexB/license-expression"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=9429839cdc4b292ff46e88b524c6e0c9"
+
+SRC_URI[sha256sum] = "9de87a427c9a449eee7913472fb9ed03b63036295547369fdbf95f76a8b924b2"
+
+inherit pypi ptest setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-setuptools-scm-native \
+ ${PYTHON_PN}-wheel-native \
+"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-booleanpy \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}