aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-langtable_0.0.56.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-08-18 12:40:35 +0300
committerKhem Raj <raj.khem@gmail.com>2021-08-19 09:56:43 -0700
commitf601322416e219cdc95452bed44d25587adab8d1 (patch)
tree5f63907b64308366a735e743c975836a96100fe8 /meta-python/recipes-devtools/python/python3-langtable_0.0.56.bb
parent9f6e3b69bd6d6030858c204033a56a58cdb0b1a1 (diff)
downloadmeta-openembedded-contrib-f601322416e219cdc95452bed44d25587adab8d1.tar.gz
python3-langtable: Upgrade 0.0.54 -> 0.0.56
Upgrade to release 0.0.56: - Fallback to translations in “xx” from “xx_Zzzz” only if “Zzzz” is the main script of “xx” - Get translation changes for mt from CLDR Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-langtable_0.0.56.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.56.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.56.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.56.bb
new file mode 100644
index 0000000000..b8f052ea31
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.56.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "langtable is used to guess reasonable defaults for locale,\
+keyboard, territory"
+HOMEPAGE = "https://github.com/mike-fabian/langtable/"
+LICENSE = "GPLv3+"
+SECTION = "devel/python"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI[sha256sum] = "318af0fd616711ce5cd2a7b11a6761183ba9c1ff76a762919e08d85645fc854b"
+
+inherit pypi setuptools3 python3native
+
+DISTUTILS_INSTALL_ARGS += " \
+ --install-data=${datadir}/langtable"
+
+FILES:${PN} += "${datadir}/*"
+
+RDEPENDS:${PN} += " \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-xml \
+"