aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-langtable_0.0.54.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-10-30 15:08:40 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-04 11:09:53 -0800
commit563033d0a1c0346a31cea26901b62c6e3d02f157 (patch)
treeb98c4fd66384a4a114203913d3d5444980a0ff5f /meta-python/recipes-devtools/python/python3-langtable_0.0.54.bb
parentc808f9086b2ef2dd13b3b3c3ed3a38d67a473ff7 (diff)
downloadmeta-openembedded-contrib-563033d0a1c0346a31cea26901b62c6e3d02f157.tar.gz
python3-langtable: Upgrade 0.0.53 -> 0.0.54
Upgrade to release 0.0.54: - Add list_common_languages derived from gnome-control-center Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-langtable_0.0.54.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-langtable_0.0.54.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-langtable_0.0.54.bb b/meta-python/recipes-devtools/python/python3-langtable_0.0.54.bb
new file mode 100644
index 0000000000..b9b4069fdc
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-langtable_0.0.54.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "langtable is used to guess reasonable defaults for locale,\
+keyboard, territory"
+HOMEPAGE = "https://github.com/mike-fabian/langtable/"
+LICENSE = "GPLv3+"
+SECTION = "devel/python"
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
+
+SRC_URI[md5sum] = "bf2db4302dbed534ff322612f5f5a16e"
+SRC_URI[sha256sum] = "2a6298267586fcade84ce977736fc35102ef95d68975bc90ceaa06117d42d5a6"
+
+inherit pypi setuptools3 python3native
+
+DISTUTILS_INSTALL_ARGS += " \
+ --install-data=${datadir}/langtable"
+
+FILES_${PN} += "${datadir}/*"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-doctest \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-xml \
+"