aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-iso3166_1.0.1.bb
diff options
context:
space:
mode:
authorMartin Kelly <mkelly@xevo.com>2020-03-24 15:48:35 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-24 19:58:50 -0700
commit81bbbe8c6938f769496b290e556f8e749126307b (patch)
treeda2c3a085d521b974f860013ace8c8df896b35dd /meta-python/recipes-devtools/python/python3-iso3166_1.0.1.bb
parentd0c29d1340d91dfd63f4301a077c62bef4c3dc71 (diff)
downloadmeta-openembedded-contrib-81bbbe8c6938f769496b290e556f8e749126307b.tar.gz
python3-iso3166: add recipe for 1.0.1
Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-iso3166_1.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-iso3166_1.0.1.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-iso3166_1.0.1.bb b/meta-python/recipes-devtools/python/python3-iso3166_1.0.1.bb
new file mode 100644
index 0000000000..23fc4eb75c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-iso3166_1.0.1.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Self-contained ISO 3166-1 country definitions"
+HOMEPAGE = "https://pypi.org/project/iso3166/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695"
+
+SRC_URI[md5sum] = "53c313c7ae8721e40ddd5e7a01bbcb7e"
+SRC_URI[sha256sum] = "b1e58dbcf50fbb2c9c418ec7a6057f0cdb30b8f822ac852f72e71ba769dae8c5"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "python3-numbers"
+
+BBCLASSEXTEND = "native nativesdk"