aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipython_7.26.0.bb
diff options
context:
space:
mode:
authorzhengruoqin <zhengrq.fnst@fujitsu.com>2021-08-06 15:00:09 +0800
committerKhem Raj <raj.khem@gmail.com>2021-08-16 08:21:14 -0700
commitb655693eb004716eeaf0925e094e1c543beb96f7 (patch)
tree7c7956abd741bb1d0538dbc91ed3c2eeda51baa8 /meta-python/recipes-devtools/python/python3-ipython_7.26.0.bb
parent44492ab1b86abb023bd34adfd2dae02e2c3c31af (diff)
downloadmeta-openembedded-contrib-b655693eb004716eeaf0925e094e1c543beb96f7.tar.gz
python3-ipython: upgrade 7.25.0 -> 7.26.0
IPython 7.26 is a minor release that fixes a couple of issues, updates in API and Copyright/Licenses issues around various part of the codebase. We’ll highlight this issue <https://github.com/ipython/ipython/issues/13039> pointing out we were including and refereeing to code from Stack Overflow which was CC-BY-SA, hence incompatible with the BSD license of IPython. This lead us to a rewriting of the corresponding logic which in our case was done in a more efficient way (in our case we were searching string prefixes instead of full strings). You will notice also a number of documentation improvements and cleanup. Of particular interest are the following Pull-requests: The IPython directive now uses Sphinx logging for warnings. PR #13030. Add expiry days option to pastebin magic and change http protocol to https. PR #13056 Make Ipython.utils.timing work with jupyterlite PR #13050. Signed-off-by: Zheng Ruoqin <zhengrq.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipython_7.26.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipython_7.26.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipython_7.26.0.bb b/meta-python/recipes-devtools/python/python3-ipython_7.26.0.bb
new file mode 100644
index 0000000000..4c1d4ebd70
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipython_7.26.0.bb
@@ -0,0 +1,28 @@
+SUMMARY = "IPython: Productive Interactive Computing"
+HOMEPAGE = "https://ipython.org"
+AUTHOR = "The IPython Development Team <ipython-dev@python.org>"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING.rst;md5=59b20262b8663cdd094005bddf47af5f"
+
+PYPI_PACKAGE = "ipython"
+
+SRC_URI[sha256sum] = "0cff04bb042800129348701f7bd68a430a844e8fb193979c08f6c99f28bb735e"
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-setuptools \
+ ${PYTHON_PN}-jedi \
+ ${PYTHON_PN}-decorator \
+ ${PYTHON_PN}-pickleshare \
+ ${PYTHON_PN}-traitlets \
+ ${PYTHON_PN}-prompt-toolkit \
+ ${PYTHON_PN}-pygments \
+ ${PYTHON_PN}-backcall \
+ ${PYTHON_PN}-pydoc \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-pexpect \
+ ${PYTHON_PN}-unixadmin \
+ ${PYTHON_PN}-misc \
+ ${PYTHON_PN}-sqlite3 \
+"
+
+inherit setuptools3 pypi