aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
diff options
context:
space:
mode:
authorZheng Ruoqin <zhengrq.fnst@cn.fujitsu.com>2021-01-26 09:13:36 +0800
committerKhem Raj <raj.khem@gmail.com>2021-01-28 10:52:00 -0800
commit87ebf80fa47f157cc66732f0628100b6acb068a2 (patch)
tree658522f80e15a3c8de3b4334fdc248ec08d88c3d /meta-python/recipes-devtools/python/python3-ipy_1.01.bb
parent4e6508cb71f0c5368d7e721f23ee4c9ec862cfed (diff)
downloadmeta-openembedded-contrib-87ebf80fa47f157cc66732f0628100b6acb068a2.tar.gz
python3-ipy: upgrade 1.00 -> 1.01
Version 1.01 (2020-12-01) ------------ * Update to support up to Python 3.9 Signed-off-by: Zheng Ruoqin <zhengrq.fnst@cn.fujitsu.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ipy_1.01.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy_1.01.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipy_1.01.bb b/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
new file mode 100644
index 0000000000..c141f6865f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
@@ -0,0 +1,32 @@
+SUMMARY = "IPy - class and tools for handling of IPv4 and IPv6 addresses and networks"
+DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
+in a fashion similar to perl's Net::IP and friends. The IP class allows \
+a comfortable parsing and handling for most notations in use for IPv4 \
+and IPv6 Addresses and Networks."
+SECTION = "devel/python"
+HOMEPAGE = "https://github.com/autocracy/python-ipy"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6"
+
+SRC_URI[md5sum] = "d6cf83e7f418ebbd23324ba1c658b907"
+SRC_URI[sha256sum] = "edeca741dea2d54aca568fa23740288c3fe86c0f3ea700344571e9ef14a7cc1a"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/test/
+ cp -rf ${S}/test/* ${D}${PTEST_PATH}/test
+}
+
+PYPI_PACKAGE = "IPy"
+
+BBCLASSEXTEND = "native"